Sjabloon:NoteBoxPackage: verschil tussen versies

Uit informatiestandaarden
Ga naar: navigatie, zoeken
Regel 7: Regel 7:
 
</td>
 
</td>
 
<td class="mbox-text" style="border: padding: 0.25em 0.9em; width: 100%;">MedMij uses the FHIR Packaging mechanism. This conveniently bundles all examples, profiles and other conformance resources you need into a single download. For more background information see the [[{{{3}}}|the FHIR implementation guide]]. This version of the information standard depends on '''[{{{1}}} Nictiz package {{#switch: {{{2}}}
 
<td class="mbox-text" style="border: padding: 0.25em 0.9em; width: 100%;">MedMij uses the FHIR Packaging mechanism. This conveniently bundles all examples, profiles and other conformance resources you need into a single download. For more background information see the [[{{{3}}}|the FHIR implementation guide]]. This version of the information standard depends on '''[{{{1}}} Nictiz package {{#switch: {{{2}}}
  | 1.1.x = 1.1.2                  <!-- latest patch for version 1.1 -->
+
  | 1.1.x = 1.1.2                  <!-- latest patch for nictiz.fhir.nl.stu3.zib2017 version 1.1 -->
  | 2018.06 = 1.0.0          <!-- latest version for release 2018.06 -->
+
  | 2018.06 = 1.0.0          <!-- latest version for MedMij release 2018.06 -->
  | 2019.01 = 1.1.2            <!-- latest version for release 2019.01 -->
+
  | 2019.01 = 1.1.2            <!-- latest version for MedMij release 2019.01 -->
 
  | #default = {{{2}}}
 
  | #default = {{{2}}}
 
}}]'''. Please note that the direct links to the various conformance resources below will take you to the latest version, which might not match the package version. At time of writing, there is no way to render the conformance resource as found in the package. This is on the roadmap for Simplifier.
 
}}]'''. Please note that the direct links to the various conformance resources below will take you to the latest version, which might not match the package version. At time of writing, there is no way to render the conformance resource as found in the package. This is on the roadmap for Simplifier.
Regel 41: Regel 41:
  
 
== Beheer van FHIR Package versies en MedMij releases ==
 
== Beheer van FHIR Package versies en MedMij releases ==
* Als je een nieuwe FHIR packageversie maakt dan hoef je vanaf nu alleen nog maar het sjabloon bij te werken met de relevante versie: <br/><nowiki>|</nowiki> 1.1.x = 1.1.2<br/>wordt dan<br/><nowiki>|</nowiki> 1.1.x = 1.1.3<br/><br/>Op dit moment gebruiken we 2019.01 als parameter nog nergens, maar deze moet je wel bijhouden om hem relevant te houden. Op dit moment is 2019.01 gelijk aan 1.1.x
+
Informatiestandaarden gebaseerd op HL7 FHIR zijn gekoppeld aan een FHIR Package welke wordt gepubliceerd op [https://simplifier.net/organization/nictiz Simplifier.net] in het betreffende project. De meeste informatiestandaarden tot nu toe staan onder hetzelfde project [https://simplifier.net/nictizstu3-zib2017 NictizSTU3-Zib2017]. Hier staan de zib-gebaseerde artefacten en een aantal dingen die daar historisch in zijn geplaatst zoals profielen voor huisartsen die nog niet op zibs zijn gebaseerd. In de toekomst zullen informatiestandaarden in groeiende mate in hun eigen project komen en dan vooral een afhankelijkheid op dit project NictizSTU3-Zib2017 declareren. Wanneer er een nieuwe zib-release wordt geïmplementeerd zal het belang van NictizSTU3-Zib2017 als project afnemen.
* Als je een nieuwe MedMij release maakt zou er een regel in het sjabloon bij moeten komen, bijvoorbeeld:<br/><nowiki>|</nowiki> 2019.02 = 1.1.3
+
 
 +
* Als het package [https://simplifier.net/packages/nictiz.fhir.nl.stu3.zib2017 nictiz.fhir.nl.stu3.zib2017] een nieuw patchnummer krijgt dan moet in dit sjabloon de versie worden bijgewerkt met de relevante versie: <br/><nowiki>|</nowiki> 1.1.x = 1.1.2<br/>wordt dan<br/><nowiki>|</nowiki> 1.1.x = 1.1.3<br/><br/>Op dit moment gebruiken we 2019.01 als parameter nog nergens, maar deze moet je wel bijhouden om hem relevant te houden. Op dit moment is 2019.01 gelijk aan 1.1.x
 +
* Als je een nieuwe MedMij release maakt dan moet er in dit sjabloon een nieuwe regel bij komen, bijvoorbeeld:<br/><nowiki>|</nowiki> 2019.02 = 1.1.3
 
* Als je een nieuw package maakt waarbij minor of major omhoog gaat, dan heb je ook een nieuwe regel in het sjabloon nodig voor patch releases op die versie:<br/><nowiki>|</nowiki> 1.2.x = 1.2.0
 
* Als je een nieuw package maakt waarbij minor of major omhoog gaat, dan heb je ook een nieuwe regel in het sjabloon nodig voor patch releases op die versie:<br/><nowiki>|</nowiki> 1.2.x = 1.2.0
 
* Als je in een pagina een versie meegeeft die de switch niet kent voor vervanging dan plaatst hij hem gewoon as-is
 
* Als je in een pagina een versie meegeeft die de switch niet kent voor vervanging dan plaatst hij hem gewoon as-is

Versie van 15 apr 2019 om 08:28

De sjabloonbeschrijving hieronder wordt niet afgebeeld wanneer het sjabloon wordt geplaatst.

Doel

Dit sjabloon creëert een NoteBox met basale informatie over het FHIR Package op Simplifier dat nodig is bij een informatiestandaard.

De verwachting hierbij is deze wordt gebruikt boven een opsomming van de benodige profielen/StructureDefinitions uit het betreffende package.

Gebruik

Er zijn 3 parameters in volgorde vereist:

  • De volledige link naar het betreffende package op Simplifier
  • De versie van het package of de versie van de release. Dit mag een vaste versie zijn zoals 1.1.0, of een variabele versie 1.1.x. Hiervoor moet in dit sjabloon bekend zijn wat de nieuwste patchversie is binnen versie 1.1
  • De link naar de algemene FHIR Implementatiegids pagina op deze wiki
{{NoteBoxPackage|<link>|<versie>|<FHIR IG>}}

Voorbeeld met variabele versie

{{NoteBoxPackage|https://simplifier.net/NictizSTU3-Zib2017/~packages|1.1.x|MedMij:Vdraft_FHIR_IG}}

geeft:

Voorbeeld gebaseerd op release

{{NoteBoxPackage|https://simplifier.net/NictizSTU3-Zib2017/~packages|2019.01|MedMij:Vdraft_FHIR_IG}}

geeft:

Beheer van FHIR Package versies en MedMij releases

Informatiestandaarden gebaseerd op HL7 FHIR zijn gekoppeld aan een FHIR Package welke wordt gepubliceerd op Simplifier.net in het betreffende project. De meeste informatiestandaarden tot nu toe staan onder hetzelfde project NictizSTU3-Zib2017. Hier staan de zib-gebaseerde artefacten en een aantal dingen die daar historisch in zijn geplaatst zoals profielen voor huisartsen die nog niet op zibs zijn gebaseerd. In de toekomst zullen informatiestandaarden in groeiende mate in hun eigen project komen en dan vooral een afhankelijkheid op dit project NictizSTU3-Zib2017 declareren. Wanneer er een nieuwe zib-release wordt geïmplementeerd zal het belang van NictizSTU3-Zib2017 als project afnemen.

  • Als het package nictiz.fhir.nl.stu3.zib2017 een nieuw patchnummer krijgt dan moet in dit sjabloon de versie worden bijgewerkt met de relevante versie: 
    | 1.1.x = 1.1.2
    wordt dan
    | 1.1.x = 1.1.3

    Op dit moment gebruiken we 2019.01 als parameter nog nergens, maar deze moet je wel bijhouden om hem relevant te houden. Op dit moment is 2019.01 gelijk aan 1.1.x
  • Als je een nieuwe MedMij release maakt dan moet er in dit sjabloon een nieuwe regel bij komen, bijvoorbeeld:
    | 2019.02 = 1.1.3
  • Als je een nieuw package maakt waarbij minor of major omhoog gaat, dan heb je ook een nieuwe regel in het sjabloon nodig voor patch releases op die versie:
    | 1.2.x = 1.2.0
  • Als je in een pagina een versie meegeeft die de switch niet kent voor vervanging dan plaatst hij hem gewoon as-is